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WEBPAGE DESIGN WITH FRONT PAGE 2000 
Session 1-6 

 
 
 
What Makes A Good Website? 
 
In short, you will want to pay close attention to the following items: 

1) Your site should contain content your visitors what to see. 
2) Your pages should be easy to read so as to find the important content quickly. 
3) There should be a clear navigation of your site/pages so that visitors know where to go to 

get the content they want. 
 
** Reference the additional handout “CREATING A USABLE WEBSITE” by Katherine Nolan 
for more on creating a great website. 
 
Web Page Do’s and Don’ts 
 

Don’t: 
 Use blinking or flashing elements. 
 Use a hyperlink labeled “Click here”. 
 Use large images that take forever to 

download. 
 Use busy backgrounds. 
 Use colors that do not contrast well (text vs. 

background). 
 Use “Under Construction” graphics. 
 Use Pop up windows. 
 Use every effect in the book on one page. 
 Create long scrolling pages. 
 Let content get outdated. 
 Use special font formatting. 
 Use sounds (unless it’s a music site). 
 Don’t get discouraged.  Creating web pages 

will get easier with just a little practice.

Do: 
 Make the site with the user in mind. 
 Plan your pages and content. 
 Make pages simple. 
 Keep graphics small and simple. 
 Use high-contract color schemes, like black and 

white. 
 Add “ALT” tags to all images. 
 Make links clear and understandable. 
 Keep all important content within three clicks of 

main page. 
 Provide navigation bars/tools. 
 Design pages for 640x480 browsers. 
 Be consistent in styles, color, and layout from one 

page to another. 
 Proof read your pages for spelling and grammar. 
 Add links for people to contact you. 
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Guidelines For TCS Pages? 
 

All pages hosted by Troy City Schools and all pages linked to from TCS pages must strictly 
adhere to the following guidelines set forth by the Board of Education to ensure the safety of 
Troy students and to ensure that TCS’s site is legal. 
 

TROY SCHOOLS INTERNET CONTENT GUIDELINES 
1. Unless a parent or guardian requests otherwise to the child's school office, images or 

names of students (not both) can be used so long as the following is true:  
A. The student's parent or guardian has not made a request to the school office to 

restrict Internet posting.  
B. Pictures and names can not be used together to identify a student.  
C. In the case of sporting events or extra-curricular activities, images with names on 

shirts can not be posted.  Lists of jersey numbers can not be posted.  
D. In the case of large group pictures, it may be acceptable to post names so long as 

the names are not in order with the image and can not identify an individual.  
* If parents decline to accept these guidelines, they should make a request to the child's school office. 
 

2. Material on the Troy School site should be complementary to Troy Schools and shall fall 
into one of the following categories:  
 Provides an educational service to the students of Troy Schools.  
 Provides a service to the staff of Troy Schools  
 Enhances the communications to and interaction with the parents of Troy Schools  
 Serves as outreach to the community.  For example, it may inform the public of 

upcoming events and activities or provide information about recent public events, 
meetings, or activities. This material should be similar in content to what is 
traditionally communicated through local news media.  

 Demonstrates the completion of a student or class projects.  
 

3. All web pages should be void of any photos, text or references to profanity/inappropriate 
language, sexually explicit content, tastelessness, alcohol and drug use, nudity, crime, 
and violence.  

4. Web pages should not contain any content that is in violation of copyright laws.  
5. Web pages should not link to any other sites that are in violation of any Troy Schools 

Internet Content guidelines. All links should be well researched and should enhance the 
value of the content. 

6. No TCS web page shall link to a site outside the district that implies that it is in any way 
related to Troy City Schools, or could be construed to be related, especially by use of the 
Troy Schools’ name, images, or other content. 

7. The location of web pages within the Troy Schools site should be appropriate with the 
content.  Materials relevant to a building should be available from that building's web page.  

8. All email addresses referenced should be school addresses. They should not be personal 
or student addresses.  

9. All pages should (but not required) include the following:  
 Creator's name or sponsoring teacher (preferably in a “mailto” hyperlink format) 
 Last date the page was updated  
 A link to the TCS home page or a link to the building’s home page  
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Why Front Page? 
 
TCS have decided to use FrontPage (FP) as the only web editing software for TCS because (1) it 
is about the easiest web editing software to use today, (2) it is a Microsoft product that we can 
get with Office, and (3) it allows users to edit directly to our web server from school and home.  
Because it is a Microsoft product, FP has many of the same tools and buttons as other Office 
programs.  Every PC purchased since the year 2000 will have FP. 
 
 
Who can use FP2000? 
 
Any students or staff can use FP at TCS.  However, because of the delicate security on our 
server, we require that staff attend a FP class in order to post right to our server.  For those staff 
members who don’t attend, and all students, we have set up a separate location for you to publish 
your pages.  Then when your pages are ready to post, you will need to contact Scott Hamman 
and he will post at his next available time.  Student web pages will first need to be approved by 
the supervising teacher or principal.  Note: Anyone found giving out their password, letting 
students modify pages on the server, or messing with pages of other users will have their 
web page privileges restricted. 
 
 
Getting Started with FP 
 

1) Locate a PC with FrontPage. 
2) Log on as yourself. 
3) Go to [Start] > Programs > and run “Microsoft FrontPage”. 

 
For users who have taken the 1st web class, follow these steps to connect to our web server so 
that you can directly edit your web pages. 

4) Go to <File> and choose “Open Web”. 
5) In the “Web Name” field, type:  http://www.troy.k12.oh.us/  and add to the end of this 

your building code below: 
~cn/  ~ck/  ~for/  ~hk/  ~hy/  ~ky/  ~vc/  ~tjh/  ~ths/ ~boe/ 

6) Click “Open” 
 
TIP:  Once you have connected to a web the first time, a shortcut to that web should appear each 
time after step 4 that you should use.  There should also be a link under <File> Recent Web> 
during future use. 
 
When working on the server, setup your own folder to house your pages so that no one else 
bothers them.  Follow the folder structure that each building has.  For instance, if you teach 
English at THS, create a new folder under the English folder with your name (see instructions 
below on creating new folders). 
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Know the Lay of the Land 
 
FP has several windows, toolbars, and options.  There are three main panes (when connected to a 
web).  The pane on the left has shortcuts to different FP services (you have no need to use these 
at this time).  The middle pane shows the contents of the web (folders and files).  To open a 
folder or a file, double-click on it in this window.  The main pane on the right is where you will 
do all your editing. 
 

 Making a new folder:  To make new folder, go to the center pane.  Right click on the 
folder in which you desire to add the new subfolder to.  Choose “New Folder”.  Give the 
new folder a name and press Enter.  There is your new folder to add to. 

 
When a page is open in the main pane, you will see 3 tabs along the bottom:  Normal, HTML, 
and Preview.  Normal is where you can format using WYSIWYG tools (like Word).  HTML is 
where you can modify the actually coding.  Preview attempts to show you what your page looks 
like in a browser (not always a true view).  You can switch between these tabs at any time. 
 
Toolbars are across the top and work just like other Office applications, allowing you to save, 
insert, and format. 
 
 
Save your page 
 
To save your page, go to <File> and choose “Save”.  Browse to the folder you want to save your 
page in.  That folder name must appear in the “Look in” field at the top of the window.  Give it a 
file name (see rules below).  Click “Save”.  Remember to save every 10-15 minutes! 
 
When naming a file or folder, follow these rules: 

 You can use any letter (upper or lower case), number, or the following symbols: ~ - _ 
 Never use spaces or periods in a name.  Never use any other symbols except for the ones 

shown above. 
 The first page you want someone to view in a folder should always be named 

“Default.htm”, “Index.html”, or “Index.htm”.  The server will attempt to open these file 
names first (in the order they appear above). 

 
After your page is saved, close the page (not the program) by clicking on the X in the upper 
right-hand corner (the bottom set). 
 
Now open the page back up by locating it in the center pane and double clicking the file. 
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TEXT: 
 
Open a blank page.  In the main pane (make sure you’re in NORMAL view), you can type text 
just like you would in Word.  Please note the following: 

 At the end of a line, if you use just the ENTER key, it will make a double-space (paragraph).  
To make a single-space return, hold down the SHIFT key while pressing ENTER. 

 
Now you can format your text.  To do this, highlight the text you want to change then use the 
toolbar buttons at the top.  Here are options you have: 
 

 
 With the 1st field, you can use pre-defined styles.  I would recommend NOT using these 

until you are more familiar with FP. 
 The 2nd field allows you to change the font face.  I strongly recommend leaving this as 

“default font” because many people may not have the font you choose installed, thus your 
page will not display as you intended. 

 The 3rd field changes font size.  The lower the number, the smaller the font.  “3” is the 
default size.  This is a font style you are welcome to change.  However, larger font should 
be reserved for titles or info that demands the visitor’s attention. 

 

    Makes your text BOLD. 

    Makes your text ITALIC. 

    UNDERLINES your text.  Note: Using underline may make your visitors think that it is a link. 
 

    Will align text to the LEFT, CENTER, or RIGHT.  It will do this as a whole 
paragraph, so if you use the “Shift+Enter” to make single spaces, it will change every 
line in that block. 

 

    Will highlight text.  You can set the highlight color by using the drop-down arrow to the 
right.  Note: This will not show up correctly on all browsers, so it should be used sparingly. 

    Changes the color of the text.  You can set the color to any color you want.  However, 
make sure that the color fits with the color design principles (see “Creating a Usable 
Website” handout). 

 
Design consideration when formatting fonts: 

 Do not make all your text real big or bold and do not use a lot of all-caps text.  Using all 
CAPS, large font, and red text means that you are yelling at your visitors and is often 
hard to read. 

 Make sure that the color and style you choose is easily readable on the background that 
you choose.  Sticking with dark/black text on a light/white background is a good idea. 
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Additional font features are available by right-clicking on your selected text and choosing “Font”.  
However, most of these font styles are only visible in newer versions of Internet Explorer. 
 

For more specific design considerations with fonts, please see page 5-7 
of the “Creating A Usable Web Site” handout. 

 
 
 
 
 
PAGE FORMAT: 
 
There are several things that you can do to setup and format your webpage.  To make these 
changes, right-click anywhere on your page and choose “Page Properties…”.  Here is what you 
can customize: 
 
General Tab: 
Title – Give your page a title.  You can enter any text you want (no limitations).  However, since 

your title will appear at the top of your webpage and in users’ favorites list, you should 
give it a clear and understandable name. 

>> You do not need to change any other options on this tab at this time. 
 
Background Tab: 
Background Picture – Will be covered in the next session on “Images”. 
Color – Change the default colors of elements on your webpage.  You have an unlimited number 

of color options to choose from.  Just make sure that it fits with an acceptable color 
scheme. 
 Background:  Changes the background color of your page. 
 Text: Changes the default color of your text.  Note:  If you manually set a color for 

font (as covered earlier), it will not change when you adjust these settings. 
 Hyperlink:  Changes default color of a hyperlink.  Typically, hyperlinks are blue, but 

this may need to be changed if you have a dark background. 
 Visited Hyperlink:  A visited hyperlink is a link the user has already been to. 
 Active Hyperlink:  This is the most recently visited link where the user has clicked 

the “Back” button to return to your page.  When you have a large list of links, this 
helps the user keep their place of what the last link they clicked was. 

 
>> The other TABS do not need to be set at this time. 



 7

HYPERLINKS: 
 
Hyperlinks are about the most important feature of web pages as they allow users to navigate 
from page to page to find the info they want.  Hyperlinks should be clear and understandable to 
users so that they can quickly navigate your site.  There are 3 main types of hyperlinks: 
 
Hyperlink To A Page: 

1. Add text to your page that you want to make as a hyperlink.  TIP:  It is best to make sure 
that you have a space or line return after the text before you proceed. 

2. Highlight the text you want as a link. 
3. Right click on the selected text, and choose “Hyperlink”. 
4. In the URL field, enter the page you wish to link to. 

Note:  There are two types of links you can have, internal and external.  “Internal” links 
to a page in your site.  To make this link, such as to a page in the same folder, you only 
have to enter the file name and not the whole HTTP string.  An “external” link is to a 
page outside of your site or server.  For such a link you will need to include “HTTP://...” 
plus your full URL address.  The best way to get this it to view the page in your Internet 
browser, copy the URL address from that window, and paste it into the URL field in FP. 

5. Click OK and your text will change to a hyperlink. 
 
To change a hyperlink address, simply right click on the link and follow steps 3-5.  To remove a 
hyperlink from your text, do the same as above, but leave the URL field blank. 
 
You can also make a hyperlink to a new page.  To do this, follow steps 1-3 above.  Then, click 
on the icon of a blank paper (“Create page and hyperlink to new page”) to the right of the URL 
field.  It will ask you to pick a page format (choose “Normal Page” for a blank page).  You can 
then work on your new page if you like.  Once you save the page, a hyperlink will automatically 
be created on your first page. 
 
If you would like to format the text of your hyperlink (such as a different color), create the 
hyperlink first, select just the text within the hyperlink, and format it according to the procedure 
listed in the FORMAT TEXT section early in the handout. 
 
E-Mail Hyperlink: 
E-mail hyperlinks allow you to create a clickable link that opens the user’s E-mail program and 
address a message to you. 

1. Add text to your page that will reflect that the hyperlink is an E-mail link. 
2. Highlight the text you want as a link. 
3. Right click on the selected text, and choose “Hyperlink”. 
4. To the right of the URL field, click that icon of an envelope. 
5. In the new window, enter your E-mail address.  (e.g. “Doe-J@troy.k12.oh.us”).  Click OK. 
6. You will then see that in the URL field the text “mailto:Doe-J@troy.k12.oh.us” has been 

inserted.  Click OK and you now have an E-mail (or MailTo:) hyperlink. 
 
TIP:  You can have your E-mail address be the text for the hyperlink.  If you type in your full 
address and put a space or return after it, FP will automatically convert that text to an E-mail 
Hyperlink using the address you typed.  If you do not want FP to do this, after it changes to a 
hyperlink, immediately click the UNDO button. 
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Bookmark Hyperlink: 
Bookmarks are a great way to link users to a specific line of your page, especially when you 
have long, scrolling pages.  Typically, a bookmark is placed in the page and a hyperlink to that 
bookmark is placed at the top.  When you click on the hyperlink, it will jump the user down the 
page to that bookmark.  You can also link to bookmarks on other pages. 
 
Create the Bookmark 

1. Place your cursor at the point where you want a user to be able to “jump” to. 
2. Go to the menu bar and choose <Insert> Bookmark>. 
3. Give your bookmark a name.  It should follow conventional Internet naming standards.  It 

helps you out to make it short but understandable, as the user will not see it. 
4. Click OK and you will now see a flag icon appear.  This is a place holder for your 

bookmark and will not show up when viewed by visitors. 
 
Link to the Bookmark: 

1. Go to the point where you want to create the hyperlink to this bookmark and type your 
text. 

2. Highlight the text you want as a link. 
3. Right-click on the selected text, and choose “Hyperlink”. 
4. If the bookmark is on the same page, select the desire bookmark from the list provided 

below the URL field.  If the bookmark is on another page, first enter that page in the URL 
field and then a list of bookmarks should appear for that selected page. 

5. Click OK and your text will change to a hyperlink. 
 

For more ideas on creating good hyperlinks, reference page 9 
of the “Creating A Usable Web Site” handout. 

 
 
 
MISCELLANEOUS FRONTPAGE TIPS: 

 To create a new page, you can click on the icon of a blank paper in the upper-left toolbar.  
You can also use preset formats if you need some ideas to get started.  To access these 
formats, go to <File> New> Page>.  Choose a style you like. 
 

 To switch back and forth between open webpages in FP2000, go to <Window> and click 
on the page you want from the list at the bottom of the menu. 
 

 To open/edit a page that you are hyperlinking to in a FP window, hold down the [CTRL] 
key while you click on the link.  That linked page will open in normal view to edit. 
 

 Questions on how to do something?  Use FP help.  Go to <Help> MS FP Help>.  Use the 
“Answer Wizard” tab to type your question and quickly find an answer. 
 

 For help designing your webpage, visit the website for this class.  From Troy’s 
homepage, click on: Departments> Technology> Web Design>.  This page contains 
instructions, as well as sites for page design, clip art, and other useful stuff. 
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BULLETS, NUMBERING, INDENT 
 
To add bulleted or numbered lists to your webpage: 

1) Make sure to have a paragraph return before and after where you want your list. 
2) Place your cursor where you want the first line to start and click on the Bullet or 

Numbering icons in the toolbar. 
3) Type your first line of text.  If you desire a new line without a new bullet/number, use a 

[Shift]+[Enter]. 
4) To start a new item, press [Enter] for paragraph return.  Repeat steps 3 & 4 until done. 
5) When you are done, press the [Enter] key to give a new item, press the [Enter] key again 

and the empty item will disappear and you will be put back to the left margin. 
 
Changing List Properties: 

1) Right-click anywhere on the list you want to change and choose “List Properties”. 
2) Change the style of bullet or number by clicking on the sample. 
3) For numbering, choose the start number (if other than “1”). 
4) Click [OK]. 

 
Also under List Properties, you can choose an image as your “bullet”.  Click on the “Picture 
Bullet” tab.  Click “Specify picture”.   Click the browse button and browse for the desire 
image (use the standard procedures for adding images). 
 
A more advanced feature available to you is to make “Collapsible Outlines”.  If you check 
this box, and sub items can be hidden or shown by clicking on the parent item. 
 

Creating Sub Items: 
1) Create a list as described above. 
2) When you get to the point you want a sub item, press [Enter] to give a new item. 
3) Click the “Increase Indent” icon in the tool bar TWICE. 
4) Repeat steps 2 & 3 as many times as necessary to make as many sub lists as desired. 
5) When you want to start a new parent item, press [Enter] to create a new sub item, click 

the “Decrease Indent” icon on the toolbar TWICE for until you are back to the 
appropriate parent level. 

 
List Tips: 

 Lists are by default single spaced.  To add spaces between items, use [Shift]+[Enter] to 
add a line break and press the space bar once to add a single space on the blank line. 

 To change the properties of an individual list item, right-click on that item and choose 
“List Item Properties”. 

 
 
 
SYMBOLS: 
To insert a special symbol, like a ©, fraction, or Spanish character, there is a predefined list to 
choose from.  Place your cursor where you want the symbol, then go to <Insert> Symbol>.  
Click to select the symbol you want to insert and click the [Insert] button. 
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PREVIEW IN BROWSER: 
 
If you want to see what your page looks like, you can easily go to the preview tab in FP.  
However, how do you know that this preview is what will show in Internet Explorer?  You don’t, 
so the best this is to look at your page in IE.  FP makes this easy to do: 
 

1) Save your page. 
2) With your page open, go to the menu and choose <File> Preview In Browser>. 
3) Choose the browser you want to preview in (IE only at TCS). 
4) Choose the window size.  Default will show in whatever your current resolution is.  The 

other sizes will give you an idea of what your page may look like on PC’s with different 
resolutions. 

5) Click [Preview]. 
 
Your page will open in your browser.  You can flip back and forth between FP and the browser.  
When you make a change in FP, save the page, and then click the “refresh” button on the 
browser to see the changes. 
 
 
 
 
WORKING WITH IMAGES: 
Images are usually a great way to add interest to a document, but with webpages, you must be 
very careful.  In this session, we will look at the different ways you can insert images into your 
page, plus how to manipulate those images and how to optimize download times. 
 
 
INSERT IMAGES: 
There are 3 ways to add images to your webpage: from clip-art, from a file, or from the Internet. 
 
Clip-Art: 

1) Place your cursor where you want the image to appear. 
2) From the file menu, click <Insert> Picture> Clip Art>. 
3) Search for the image that you want.   
4) Once you find it, right-click on the image and choose “Insert”. 

The image will be inserted directly into your web page. 
5) Proceed to “Refining Your Image” on the next page. 

 
Disk or File: 

1) Place your cursor where you want the image to appear. 
2) From the file menu, click <Insert> Picture> From File>. 
3) Click on the icon of the folder & magnifying glass to the right of the URL field. 
4) Browse to the location of the file. 
5) Highlight the file and click [OK].  The image will be inserted 

directly into your web page. 
6) Proceed to “Refining Your Image” on the next page. 
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Internet: 
1) Open IE and go to the page that has the image you want. 
2) Right-click on the image and choose copy. 
3) Go back to FP. 
4) Right-click where you want to image to be placed and choose “Paste”. 
5) Proceed to “Refining Your Image” on the next page. 

 
 
 
 
REFINING YOUR IMAGE: 
 
Properties: 
There are several properties that you may want to set for your picture.  In order to do this, 
right-click on the image and choose “Picture Properties”. 
 
General Tab: 
The only thing that you want to worry about setting is the “Text” field under “Alternate 
Representation”.  Alt Text is used when a picture can not be loaded (the text will describe what 
should have been there) and will help visually impaired visitors know what you are conveying in 
the image.  Text in this field can be anything you want it to be, but should be short and sweet. 
 
Video Tab:  Ignore. 
 
Appearance Tab: 

 Alignment:  You can align your image to the left, center, or right on the page.  If you 
choose any of these 3 options, it will wrap text around the image.  “Default” will leave 
the image in-line with the text. 

 Border Thickness:  This will display a border around the image in a set number of pixels.  
“0” equals no border.  The border color will appear in whatever the default font color is, 
unless it is a hyperlink, at which point it will appear in the default hyperlink color. 

 Horizontal and Vertical Spacing:  Sets a margin around the image.  This is useful if you 
do not want text running right up to the edge of your image. 

 Size: You can set the size of the image either by pixels or percent of original size.  The 
“Keep Aspect Ratio” box should be checked to maintain the original image ratio. 
 
NOTE: You can manually change the size of the image by clicking on any of the image 
nodes with your mouse and dragging it to the desired size.  Doing this on the corner 
nodes will main aspect ratio, while the edge nodes will distort the image. 
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Image Toolbar: 
FrontPage offers several different features to manipulate your images once they are on your 
page.  By clicking on the image once, you will get nodes around the image.  You will also get 
this toolbar at the bottom of your screen that will allow you to edit your image: 
 

 
Below are some of these features: 

 Text On Image: Click on image where you would like to place some text and type.  Move 
the text box to the desired position.  Use standard formatting procedures.  This feature will not 
actually write text to your image, but just include it over the top for the viewer. 
 

 Auto Thumbnail:  After inserting a larger image, you can click this to make a small 
thumbnail that will then link to the larger copy.  FP automates this whole process for you. 
 

 Position Absolute:  After clicking this toggle button, you can use your mouse to position the 
image exactly where you want it on the page.  This is a more advanced feature and should be 
avoided if possible due to unexpected results. 
 

 Rotate/Flip:  Allows you to rotate the image or flip it.  Once the page is saved, the 
image will permanently be saved in that orientation. 
 

 Contrast/Brightness:  Adjusts the contrast and brightness of the image. 
 

 Crop: Used to crop down your image.  To use, click on the button.  You will get a separate crop 
box on the image.  Adjust this to the desired size.  When positioned, click the crop button again. 
 

 Set Transparent Color:  If you want to make one color of your image transparent, click this 
button and use the new cursor to select that color.  You can only have one color be transparent.  
It is necessary for FP to convert and save this image in GIF image format. 
 

 Color/B&W:  Will make your image black and white. 
 

 Washout:  Will lighten (washout) your image. 
 

 Bevel:  Will put a bevel around your image to make it look like a raised, 3-D image. 
 

 Resample:  Always click this button once you are done adjusting the size of your 
image.  It will resample the image to make it an optimal file size/format for download. 
 

 Hotspots:  Hot spots are used to make portions of your image hyperlink-able.  Use the 
three types of shapes to draw out the portion of your image you want to use to link.  When the 
shape is complete, you will be asked to provide a link location.  Once saved, the user can click 
on different parts of the image to go to different pages.  This feature will be covered later in the 
session (page 14). 
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SAVE YOUR IMAGE: 
 
Many of the changes you make to your image can NOT be seen correctly 
in the Preview view until you save the page (with image). 
 
When you save a webpage, all the text and coding go into one file, while each image you add to 
your page must be saved as a separate image file.  Follow the steps below when saving an image 
for the first time.  If you are working with someone else’s image, or want to keep the original, 
remember to save as a copy. 
 

1) Save your page in the normal fashion. 
2) A window will appear (“Save Embedded File”) listing each of the new/changed images 

in your page.  Click to highlight each image if you need to change the save properties (as 
listed below). 

3) To give the image file a new name, click the [Rename] button.  The normal rules of file 
naming apply.  Tip: Name your image something meaningful to you so that you know what it 
goes to.  I always name my images starting with the file name of the webpage it belongs to 
(e.g. “index_bus.gif”).  This way, the image is always list alphabetically with the webpage. 

4) To place the image in a different folder than the webpage, click [Change Folder] and 
browse to the folder where you want to save it. 

5) [Set Action] will allow you to save the image to your web as a new file, overwrite a 
current image, or leave the image where it is (used only when linking from another site). 

6) Click [OK] and your images are saved.  You will also see this message again if you add 
or change and image. 

 
 
BACKGROUND PICTURE: 
 
Instead of a solid color, you can use an image as a background to your page.  While the steps to 
doing this are simple, trying to find an image that looks good as a background and is easy to read 
text on can be very challenging.  There are many sites that offer free images for backgrounds that 
are designed to work with foreground text (see the TCS Web Design page for links). 
 

1) Right-click anywhere on your page and choose “Page Properties”. 
2) Click on the “Background” tab. 
3) Check the box for “Background picture”. 
4) Click the [Browse] button to find a background image.  This window works the same 

way as “Insert Picture From File” (see page 1).  Note:  If this is a new image, it will save 
just like any other image when you save the page. 

5) If you want the image to act as a watermark, check the “Watermark” box.  By default, 
background images with scroll with the text as you scroll a page.  Making the background 
a watermark with keep the background pinned as the page and text scrolls. 

6) Click [OK] to set the background.   
 
TIP:  If you want to edit your background image to make it lighter or a different size, first add 
the image into your webpage as a standard picture.  Make the desired changes and save the page.  
Then delete the image from the page and add the saved image in for your background.
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IMAGE MAP: 
 
An “Image Map” refers to a picture broken down into different areas, which can be made into 
hyperlinks when a visitor clicks on those specific areas of the image. 
 

                 
               BASE IMAGE:                             MAPPED AREAS OUTLINED: 

 
To create an Image Map, start with any image.  Insert your image on your page just as you would 
a standard image.  Make any modification that you desire and save the page. 
 

1. Click on the image once to highlight it.   
2. From the Picture toolbar, click on 1 of the 3 “Hotspot” drawing tools (square, circle, freeform).   
3. Use the tool to define the desired region of the image you want to make as a link.   
4. Once you close the region, a “Create Hyperlink” window will automatically come up.  

Choose your hyperlink and click [OK].   
5. Repeat these steps until you have all your regions created and defined. 

 
To change a hyperlink, right-click on the region and choose “Hyperlink”.  To adjust the region’s 
size or shape, click in the region and then click and drag the corner nodes.  To delete a region, 
click in the region to select it and press the {Delete} key on the keyboard. 
 
 
 
PAGE LOAD TIME: 
 
If you would like to know about how long your page takes to load, look in the lower right-hand 
corner of FP.  Next to the hour glass icon, it will tell you that your page takes “X seconds over 
28.8”.  This means if a visitor has a 28.8 modem, it will take that long to load the complete page. 
 
Since most people have 56K dial-up modems or cable/DSL modem, you may want to change this 
setting.  To do that, go to the menu and choose <Tools> Options>.  On the “Reports View” tab, 
change “Assume connection speed of” to the desired speed.  Click [OK].  Close and reopen 
FrontPage and the time should now reflect the new speed. 
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TABLES: 
 
When most people think of tables (in reference to computers), they think of a spreadsheet like 
MS Excel.  The gridded spreadsheet is a great way to layout data.  I have no doubt that when 
tables were developed for webpages, the programmers had spreadsheets in mind.  However, over 
the years, webpage tables have moved away from organizing numbers and to allowing complex 
layouts in webpage design. 
 
While typical webpage design is done in a linier format from top to bottom, tables allow 
designers to start to design left and right and place elements exactly where they want them.  
Tables can be made as simple or complex as designers desire.  So let’s explore how to make 
your table. 
 
The most important thing to do first is to plan how you will be using your table.  By planning 
first, you will make it easier on yourself in the end.  Get an idea of how the data/elements will 
layout and decide how many columns and rows you should need.  You can always add or 
subtract later, but it is easier to subtract, so give yourself a little extra to work with. 
 
Add A Table: 

1) Place your cursor where you want to insert a table. 
2) In the menu, go to <Table> Insert> Table>. 
3) Specify how many “Rows” and “Columns” you want. 
4) You can specify an alignment of the table on the page if you desire. 
5) Set the border size of the table in pixels.  “0” will hide the table’s border. 
6) Set “Cell Padding”.  This is the margin size within the cell, in pixels (the space between 

the border and the text/elements). 
7) Set “Cell Spacing”.  This is the margin between cells, in pixels. 
8) Set width of table.  If you want the table to automatically resize to the width of the 

content, UNCHECK the “Specify Width” check box.  To specify width, fill in the desired 
width in either pixels or percent of window.  Mark the units accordingly. 

9) When all your settings are set correctly, click [OK] and your table will be inserted. 
 
Tips for starting a table: 

 Typically, designers will set the border size to “0” when using the table as a layout tool.  
A border would only be used when using the table to show data. 

 To have images/content run together, set the cell spacing and padding, as well as the 
border size, to “0”. 

 To have a page scroll left and right (not just up and down), set the pixel width to 
something large.  The table will then stretch out to the right.  Be careful though, as such a 
table will not print past a certain width. 

 
Once you have a table added, you can add content to each cell as if it were its own little 
webpage.  That means that you can align text, add images, use horizontal lines, and what ever 
else you can imagine. 
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Table Properties: 
1) To change your table, right-click anywhere on the table and choose “Table Properties”. 
2) You can set/change all the previous layout settings, as described above. 
3) “Float” will allow you to have text wrap around your table.  This is not typically used and 

should be kept at “Default”. 
4) “Specify Height” allows you to set the height of the table.  It only makes a difference if 

you specify a number greater than the content height, and may give unexpected results. 
5) Set your border colors.  “Color” can be changed so that all borders will be that color.  

“Light” and “Dark Borders” will set the shaded colors.  Light will be the top and left 
sides, plus the grid, while Dark will be the bottom and right. 

6) Set the background color.  You can choose from the drop down list of color, or use an 
image as a “Background picture” (works the same as page background describe in 
session 3 notes). 

7) Click [Apply] to see what the changes look like and [OK] when done. 
 
Table Formatting Tips: 

 When you have a “busy” page background, set the background of the table to a solid, 
complimentary color to make font easier to read. 

 Some properties like border colors and float do not work in all browsers. 
 
 
Cell Properties: 
Along with being able to change the properties of the table as a whole, you can also change the 
properties of each individual cell.  Cell properties will override table properties, such as 
background and border color.  To change the properties of a cell: 

1) Right-click inside the cell that you want to change and choose “Cell Properties”. 
2) “Horizontal Alignment”:  will align all contents in cell to center, left, or right. 
3) “Vertical Alignment”:  will align content in a cell to top, middle or bottom.   The default 

is centered. 
4) Rows and columns spanned:  See “merging cells” below. 
5) “Specify Width”:  Set the width of the cell in pixels or percent of table.  The width will 

always go to at least the widest cell in that column or minimum allowable width of the 
included content. 

6) “Specify Height”:  Sets height of cell.  Like above, it goes to the tallest cell or the 
minimum height allowed.  Setting height will not always give expected results. 

7) “No Wrap”:  By default, a web page will wrap text in the most efficient way to be 
displayed.  If you do not want the web browser to wrap text, check the “No Wrap” box. 

8) Border Colors:  Set the color of the border for the cell.  Light and Dark are just like for 
the table.  Not all browsers will display this setting correctly. 

9) “Background”:  Set the background color of the cell or use an image as a background. 
10) Click [OK] when done.  Repeat as necessary. 

 
Cell Formatting Tips: 

 Most new designers will get confused when their cell contents do not start at the top of a 
cell.  You must remember that by default, cells align to the middle, not the top.  If you do 
not want this extra space above your content, change the alignment to “top”. 
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 You can change the properties of multiple cells at one time by simply selecting those 
multiple cells.  To do this, use one of the following methods: 

o Click and drag your mouse pointer from the first cell through to the last cell.  It 
will highlight all the cells in between. 

o Move your mouse to the left (or top) edge of the table.  As you near the edge, you 
will get a solid arrow pointing right (or down).  At the point you have that arrow, 
click and the entire row (or column) will be selected. 

Once you have the cells selected, make sure to right-click on the HIGHLIGHTED area 
and choose “Cell Properties”. 

 To copy the properties of one cell to another, use the Format Painter (paint brush icon in 
the toolbar).  Select the entire cell you want to copy the format from by holding down the 
[Alt] key and click in the cell.  Click the Format Painter button (double click if you want 
to copy to multiple cells).  Then, while holding down the [Alt] key, click on the cell you 
want to copy the format to. 

 
 
Merge Cells: 
To merge two or more adjacent cells together: 

1) Select and highlight the multiple cells you desire to merge. 
2) Right-click and choose “Merge Cells”.  The cells are merged. 

 
If you already have content in one or both cells, is will also merge the content.  The new merged 
cell will always take the properties of the first cell you chose.  You can tell if a cell is merged by 
going to the cell’s properties and look at “rows/columns spanned”. 
 
 
Split Cell: 
If you want to split two merge cells or simply want to split a single cell: 

1) Right-click in the cell you desire to split and choose “Split Cells”. 
2) Choose whether you want to split the cell into columns or rows. 
3) Enter the number of columns/rows you want the cell to be split into. 
4) Click [OK] and FP will automatically spit the cell.  (Both cells will take on the property 

of the original cell.) 
 
Add A Row/Column: 
If you need to add a row or column to your table: 

1) Put your cursor in a cell before or after the place you want to add the row/column. 
2) From the menu, go to <Table> Insert> Rows or Columns>. 
3) Choose whether you want a new row or column. 
4) Choose the number of rows/columns to add. 
5) Choose whether you want to add them above/left or below/right of the cell your cursor is in. 
6) Click [OK].  The new cells will take the properties of the cells above/left. 

 
You can also quickly add a single new row or column by right-clicking in the cell below where 
you want a row or to the right of where you want a column and choosing “Insert Row/Column”.  
To add a row or column to the end of your table, you always have to do it the long way. 
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Delete A Row/Column: 
If you have an extra row(s) or column(s) that you want to delete: 

1) Select all the cells in the entire row(s) or column(s). 
2) Right-click on the highlighted cells and choose “Delete Cells”. 

 
Tip:  You should never delete individual cells or parts of rows/columns as it can lead to 

unexpected results. 
Tip:  To delete a whole table, select all the cells in the table and choose Delete. 
 
 
Other Table Tips: 

 You can make a new table quickly by clicking on the “Insert Table” icon in the toolbar 
and then selecting (click and drag) the number of column and rows you want. 

 You can easily move whole rows or columns around.  Select the entire row/column and 
then click & drag the group of cells to the desired location. 

 If you have a table at the top of your page, or two table together, and you want to add a 
space in between, put your cursor in the upper left cell of the table and press [Ctrl]+[Enter]. 

 You can embed tables within cells (this is called nesting).  However, such actions can 
cause your page to load much slower as each nested table must be rendered before the 
parent table can be displayed. 

 To get rid of a table, but keep the content, place your cursor in the table, then go to the 
menu and choose <Table> Convert> Table to Text>. 

 If you have delineated text that you want in a table, you can highlight it and go to 
<Table> Convert> Text to Table>.  Choose the way you want FP to break the text down 
and choose [OK]. 

 
 
 
HORIZONTAL LINE: 
To insert a divider, go to <Insert> Horizontal Line>.  To change the properties of this line, right 
click on it and choose “Line Properties”.  Here you can change the width of the line, either in 
percent of the browser’s window or in exact pixels.  For percent, click the “Percent of Window” 
dot and put in a number between 1 and 100.  To do pixels, click the “Pixel” dot, and enter any 
number.  To change the height (thickness) of the line, put in any number (in pixels).  You can 
also change the color and make it solid, but these styles may only show up in newer versions of 
IE.  Note: you cannot put a horizontal line and text on the same line. 
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FRAMES: 
 
FRAMES, in web design, is a technique that divides a single webpage up into to smaller, 
individual webpages.  This allows the designer to keeps parts of their page static and other parts 
dynamic.  For example, you may have a “title page” for the site at the top, a “menu page” for the 
site on the side, and then the active viewing page taking up the rest of the screen.  This way the 
designer only has to create the menu content once and the users can access it while viewing any 
page. 
 
The draw back to frames is a blocky look, scroll bars in the middle of pages, and reduced area to 
view content.  Some designers will design their site both with frames and without frames 
because some visitors hate frames so much.  My recommendation is to use frames when 
appropriate and pay special attention to the detail settings to make your page look more 
cohesive. 
 
Create A New Frames Page: 

1) From the menu, go to <File> New> Page>. 
2) Click on the “Frames Pages” tab. 
3) Choose the frame layout style you desire.  When you single-click on each icon, a preview 

will show in the bottom right.  You can always adjust your frame layout later, so just find 
the closest style. 

4) With the style highlighted, click [OK]. 
 
Your new page will show up with the different frame areas.  Each frame area will have two 
buttons:  [Set Initial Page] and [New Page].  If you already have a page to add to your frame, 
choose Set Initial Page and browse to that page.  If you would like to start with a new page for 
that frame, choose New Page. 
 
The page in each frame is truly its own page and all previous design properties will work 
independently for each page. 
 
Change Frames Layout: 
There are several different things you can do to change the layout of your frames pages. 

 Click and drag the bar between the frames to change the size of a frame. 
NOTE:  Making one frame bigger means that another must get smaller as the height and 
width of your page will always be 100%. 

 To add another frame area, click in the current frame area that you want to split.  Then go 
to the menu and choose <Frames> Split Frames>.   Specify whether you want to split the 
frame into columns or rows.  Click [OK].  Specify a page for the new frame. 

 To remove a frame area, click in the area you want to remove, then go to the menu and 
choose <Frames> Delete Frame>.  The frame area will instantly be removed. 
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Changing the Frames Look: 
You can change the properties for each frame area to enhance the overall look of your page.  To 
do this, right-click in the frame area you want to change and choose “Frames Properties”.  The 
following items can be set for each frame area: 
 

 Name:  Each frame should have a different name that helps you identify it from the 
others (such as “title”, “menu”, and “main”).  This is especially necessary when you add 
hyperlinks and need to specify what frame the link should open in. 
 

 Initial Page:  Specifies the page that will be loaded into the frame area first when the 
users opens the frames page. 
 

 Frame Size:  Set the width and/or height by pixels, percent, or “relative”.  Pixels will 
mean that that frame will be exactly that size no matter what size the browser window is.  
Percent will be a percentage of the browser window.  Relative is “relative” to the amount 
of space left after setting the other frame sizes.  “1” means use all the remaining space. 
 

 Margins:  This sets the amount of space between the page contents and the edge of the 
frame area on all sides.  If you want your content to go right up to the edge of the page, 
set the margins to “0”. 
 

 Resizable in Browser:  If the box it checked, then the visitor will be allowed to resize 
your frame areas.  This can be helpful if the user wants to see more or less of a particular 
area, but may also give unexpected results if your pages depend on a particular frame 
size.  Usually this is not allowed and the check is removed. 
 

 Show Scroll Bars:  If you do not want the user to be able to scroll up and down the page 
(if the content requires it), set this option to “Never”.  Typically the static pages will have 
this turned off, while the dynamic pages are set to “As Needed”. 

 
You will need to repeat these setting for each frame that you want to change. 
 
To change the properties of the overall frames page, right-click in any frame and choose “Frames 
Properties”.  Then, on the bottom right corner, click the button [Frames Page].  You can change 
the following settings: 
 

FRAMES TAB: 
 Frame spacing:  This sets the width of the frames divider bars in pixels. 
 Show Borders:  Check this box if you want the gray divider bars to show.  If you 

want your page to appear more cohesive, do not use borders and use page 
backgrounds that match.  This will give the sense of being one page rather than 
separate frames. 

 
OTHER TABS: 

 Change the settings of the other page tag tabs as if it were a normal page.  You will 
especially want to set the page title as this is what will show on the title bar instead of 
the titles of the individual frame pages. 
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Hyperlinks In Frames: 
Let’s say you want people to click on a link in your “menu” frame and have the page load in the 
“main” frame.  To do this: 

1) Create a hyperlink as usual in your “menu” frame (or any such frame). 
2) Choose the page you wish to link to as usual. 
3) In the lower right section of the window, you will see a “Target frame” option.  Click on 

the pencil with 3 dots to the right of this field. 
4) Choose the frame name you wish the page to load in (usually named “main”).  You may 

also choose to have the page open as a full window (“breakout” of frames) by choosing 
“Whole Page”, or in a new window, by choosing “New Window”. 

5) Click [OK] twice. 
 
Other Frames Topics: 

 Frames View Tabs:  When working in a frames page, you will get two addition “view” 
tabs at the bottom of your screen.   

o “No Frames” will allow you to create an alternate page in case someone’s 
browser can not display frames.  As this is very rare anymore, nothing is usually 
set in this view.  

o “Frames Page HTML” will allow you to edit the HTML code of the frames page. 
 

 Saving:  When you go to save your frames page, you will get a few extra windows.  You 
will first be asked to save each of your individual pages for each frame area (if you 
created them as new pages).  A preview to the right will highlight in blue the page/frame 
area it is asking you to save.  Save each page as you would normally save a single page.  
Once all the individually pages are save, FP will then ask you to save the overall Frames 
Page.  Save this as if it were an individual page. 
TIP: If your individual pages will be excusive to the frames, give them names that relate 
to the overall frames page.  Such as, if you name your Frames Page “frames.html”, then 
name the page for the title area “frames_title.html”.  This way, all your pages relating to 
the frames stay together when you are looking at your files. 
 

 Edit Page Content:  You can edit to content on the individual pages in your frames page 
by simply working on the page as normal.  You may be limited by what you can see, 
however.  If this is a problem, once you save your frames page, go to your file list and 
open the individual page and work on it stand-alone.  Any changes made and saved here 
will automatically show up in the frames page you are working on. 
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PAGE INCLUDES: 
 
You can think of “page includes” as a lot like frames.  But instead of your “static” pages/content 
being static on the screen, the content is included into a dynamic page automatically, allowing the 
static content to scroll with the dynamic content. 
 
Basically, you will still need to create a static page for each static element you want on your 
dynamic page.  Once you have these pages saved, you will insert them into your dynamic pages 
as elements.  Then whenever that page is viewed, the dynamic page will “include” the content of 
the static page to make all the content appear as if it were on one page. 
 
Why use page includes?  You can create one static page and include it in many different dynamic 
pages.  You can then edit the one static page by itself and the new content will immediately 
appear on the pages where you used it as an include.  You can start to see how it helps on 
maintenance and updates. 
 
Include A Page: 
Before you start this process, you must have a page already created that you want to include. 

1) On the page where you want to include a separate page, place your cursor where the 
include should appear. 

2) From the menu, go to <Insert> Component> Include Page>. 
3) Select the page you want to include.  Use the [Browse] button if necessary. 
4) Click [OK].  A code line will briefly appear and then the contents of the included page 

will be displayed. 
NOTE:   You can NOT edit the contents of the included page from this screen.  You must 
always go back to the original files 

 
Page Include Tips: 

 To change the source name of the page include, right click anywhere on the page include 
element and choose “Include Page Properties”.  Change the file name and click [OK]. 
 

 To delete a page include element, click once on the element to highlight it and press the 
[Delete] key on the keyboard. 
 

 Background/page properties from the included page will not be displayed.  Instead, the 
included pages will take on the properties of the page it is being included into. 
 

 If you want to use a page include as a menu bar down the side of your page, create a 
simple table with two columns in the dynamic content page.  Insert the included page into 
one column and then put your page content in the other.  Adjust the table properties to 
your design intent (e.g.: set column sizes and remove the table border). 
 

 Page Includes (as used in FP) will only work with servers that have FP extensions 
installed (see notes from session 4).  You can also only include pages within your 
building’s Web. 
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FORMS: 
Forms can be an easy way to collect information from visitors.  Setting up forms is real simple.  
The hard part is deciding which format you want to collect the data in.  The two main types are via 
E-mail or into a Microsoft Access database.  FrontPage makes both of these processes rather 
straight forward. 
 
Add A Form: 

1. You can start with a new page or insert the form into an existing one. 
2. Place your cursor where you want to form to appear. 
3. From the menu, choose <Insert> Form> and then “Form”. 

TIP:  When working with forms, it is easier to have the Forms toolbar open.  To do this, 
go to <Insert> Form> and then click on and drag the dark grey bar at the top of the 
“forms” menu out onto your screen.  The options from the menu will become available in 
a toolbar that you can then place at the top of your screen. 

4. Once you have inserted a form, you will get a large dashed box with a “Submit” and 
“Reset” button. 

5. Insert form fields into this form area.  Use the following field types listed below. 
6. Set the properties of each form field as needed (see below).  To do this, right-click on 

each form item and choose “Form Field Properties”. 
7. Add text for labels.  Add any additional text that may be needed to explain your form. 

 
Form Field Types & Properties: 
One-Line Text Box:   

Use:  typing a single line entry 
Example:  name, phone number, E-mail address, single word answer. 
Properties:  Width – width of field in characters; 

Password Field – will show all text as *, hiding private content like passwords. 
Validate:  Data Type – Text, Integer, Number; 

Numeric Format – Format of number if specified above; 
Data Length – can set a minimum and/or maximum number of characters required; 
Data Value – text in the filed must be greater than and/or less than a certain value. 

 
Scrolling Text Box: 

Use:  multi-line responses  
Example:  comments, long answers 
Properties:  Width – width of field in characters; 

Number of Lines – the number of rows visible at one time (users can always type 
as much as they want and the box will scroll). 

Validate:  Data Type – Text, Integer, Number; 
Numeric Format – Format of number if specified above; 
Data Length – can set a minimum and/or maximum number of characters required; 
Data Value – text in the filed must be greater than and/or less than a certain value. 
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Check Box: 
Use:  choose a “Yes/No” response to a individual item 
Example:  “Do you want to receive a reply?”, “Check each of the following items that apply.” 
Properties:  Value – the data that you want to be saved only if the box is checked (if not 

check, then no value will be sent); 
Initial State – the box is check or not checked by default. 

Validate:  None 
 
Radial Button: 

Use:  choose one item from a group (can only choose one option from that set) 
Example:  “Which option do you prefer?”, True/False 
Properties:  Value – the data that you want to be saved only if that button is selected; 

Initial State – the button is selected or not selected by default (only one button in a 
group can have this option set as selected). 

Validate:  Data Required – user must have one option in that set selected. 
Notes: 1) To tie individual button into a set, make sure each button name is the same. 

2) To make users select their choice, make sure all buttons are marked as 
    “Not Selected” and “Data Required” is checked. 
3) When working with sets, set all names the same, then choose validation 
    for just one button.  This will set validation for the whole group. 

 
Drop-Down Menu: 

Use: choose from a predefined list of options/values. 
Example:  building name, “Mr./Mrs./Ms.”, “Select the option below.” 
Properties:  Add options – Click the [Add] button for each option that you want to 

provide.  Enter the “Choice” name to be displayed.  If you want the value saved to 
be different from the Choice name, check the “Specify Value” box and enter the 
desired value.  Specify if you want that item to be selected by default (only one 
item can be set as such).  Press [OK] and repeat as necessary.; 
Allow Multiple Selection – If you would like users to be able to pick more than 
one response, set this to “Yes”. 

Validate:  Data Required – user must have one option highlighted/selected; 
Disallow First Choice – will not accept the default (selected) item. 

Notes: Often times, designers will make the first option “Choose One” and then set 
“Disallow First Option”.  Not only does this instruct the user on what to do, it 
forces them to make a selection. 

 
Button: 

Use:  not used in simple forms except for “Submit” and “Reset”. 
Example:  Submit, Reset 
Properties:  Value/Label – Text displayed on the button; 

Button Type – “Normal” = advanced use, “Submit” = Submit the form, 
 “Reset” = Resets the form data to default. 

Validate:  None. 
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Set Form Destination: 
1. Right-click anywhere in the form area and choose “Form Properties”. 
2. Choose the “Store Results” option that you wish to use. 

a. Send To –  File Name: Saves the results to a delineated text file.  Not commonly 
used as there are better ways to review data submitted. 

b. Send To – E-mail Address:  Sends the results of each submission to you as an E-mail.  
Enter your full address in this field and delete the contents of “File Name” field. 

c. Send To Database:  Will save and compile all results into an Access database. 
d. Send To Other:  Can send results to another web page, like ASP (advanced use). 

3. Click the [Options] button. 
4. For sending to file or E-mail… 

a. If you are saving to file, fill in the first tab (File Results) with the file location and 
format style. 

b. If you are sending via E-mail, fill in the second tab (E-mail Results) with address, 
E-mail format (“Formatted Text” recommended), and E-mail header.  If you want 
the message to contain a certain subject line for your benefit, fill in “Subject 
Line”.  If you want the message to have a “Reply To”, fill in a specific address or 
the field name from your form that would contain an E-mail address. 

c. Under the “Confirmation Tab”, enter the page that you wish visitor to be taken to 
once the results are successfully submitted.  If you leave this field blank, a default 
confirmation page will be displayed, but will not allow visitor to travel forward. 

d. On the “Saved Fields” tab, choose the field names that you want to be sent. 
e. Click [OK] and go to step 6. 

5. For saving to a database… 
a. Choose you database connection (this is a FP link to a database on the server).  If 

you have not previously setup a database connection, then click the button  
[Create Database] and a database with connection will be created for you. 

b. You can choose a confirmation page and error page if you like where visitors will 
be taken to once the results are successfully submitted.  If you leave these fields 
blank, a default confirmation page will be displayed, but will not allow visitor to 
travel forward. 

c. On the “Saved Fields” tab and the “Additional Fields” tab, choose the field names 
that you want to be saved.  They should match up to a corresponding field name 
in your database. 

d. Click [OK]. 
6. If you would like to have additional hidden fields sent/saved, click on the [Advance] 

button and add field names and values.  Otherwise, click [OK] to return to your webpage. 
 
>> Save your web page and test it to make sure it works as expected. 
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Form Notes: 

 When sending results via E-mail, all results will have the “Webmaster” name in the 
“From” field.  Unless you specified a Reply-To address in your setup, any “replies” to 
the message you received will be sent to the Webmaster. 

 When creating a form to be E-mailed, make sure that the page is saved with an HTML 
extension, not as an Active Server Page (.ASP), otherwise the form will not work. 

 Databases are stored on your root Web under a folder “FPDB/”.  To access your 
database, find your file under this folder and double click on it.  Access will open the 
database to show you the results.  Note that a database created under FP will be saved as 
an Access 2000 file and cannot be opened with Office 97. 

 The “Reset” button will always reset the form data to what was there when the page 
loaded (usually blank).  It is not necessary to have the button and it can be deleted. 

 You can rename the “Submit” button to anything you desire so long as the button type is 
still checked as “Submit”. 

 It is possible for visitors to press the [Enter] key in some fields and end up submitting 
their results prematurely.  A tip to avoid this is to make all fields required, or to make one 
specific field required asking if they are finished. 

 
 
 
 
FRONTPAGE COMPONENTS: 
 
FrontPage has several add-in features for adding some unique tools to your page.  These 
components turn what would be complex code for the designer into a simple click of the mouse.  
However, there is one stipulation to use most of these features; that is, you must have what are 
called “FrontPage Server Extensions” installed on your web server.  Not all web hosting sites 
offer this, so it is something to ask about if you are look for a host.  TCS has these extensions. 
 
Hit Counter: 
A hit counter will keep track of how many times visitors view a particular page.  This can be 
helpful to track how popular your pages are, but should not always be relied on as an accurate 
count.  To include a hit counter on your page: 

1) Place your cursor where you want the hit counter to appear. 
2) Go to the menu and choose <Insert> Component> Hit Counter>. 
3) Choose the visual style of counter to be displayed. 
4) Check the box marked “Reset counter to” to reset your counter to zero (usually used after 

a page has been up for a while). 
5) If you want to show a fixed number of digits (which means leading zeros), check the box 

“Fixed number…” and choose the number of digits you want to appear. 
6) Click [OK]. 
7) The text “[Hit Counter]” will appear where your count will be displayed at.  You must 

view your page in a web browser for this to show. 
8) To change properties of the counter, double-click on the counter text and change the 

properties as specified in steps 3-6. 
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Scrolling Banner: 
You can add some dynamic messages to your page with scrolling banners (a.k.a. Marquees).  
Marquees are a “love/hate” web element, meaning visitors either love them or hate them.  
Because of this, you may want to use them wisely.  To add a scrolling banner to your page: 

1) Place your cursor where you want the marquee to appear. 
2) Go to the menu and choose <Insert> Component> Marquee>. 
3) “Text”:  Type the text you want to appear scrolling across your page. 
4) “Direction”:  Choose the direction you want the text to scroll. 
5) “Speed”:  Set “Delay” to the time between moves (in milliseconds) – lower the number, 

the faster the text.  Set “Amount” to the distance the text should move at each time (in 
pixels) – higher the number, faster the text. 

6) “Behavior”:  Set the behavior of the marquee to:  “Scroll” will continuously scroll the 
text across the screen in one direction, “Slide” will slide the text in from one side to the 
other and stop it, or “Alternate” will scroll the text back and forth. 

7) Set the size of the marquee “box”.  You may want to change the text alignment too. 
8) Set the “Background color” (if desired). 
9) To change the text style, click on the [Style] button and choose “Font”.  Set the styles that 

you want (note: font faces will not always display correctly). 
10) Click [OK]. 

To view your marquee, go to the “Preview” tab.  To edit, double-click on the marquee in 
“Normal”. 
 
 
Hover Button: 
FP provides a hover button component to allow you to create button hyperlinks and makes those 
buttons more interesting by giving them an effect when your mouse cursor rolls over them.  To add 
a hover button to your page: 

1) Place your cursor where you want the button to appear. 
2) Go to the menu and choose <Insert> Component> Hover Button>. 
3) Type the text that should appear on the button. 
4) Change the font to the desired appearance. 
5) Enter the page/file you wish to hyperlink to.  Use the [Browse] button if necessary. 
6) Change the Button Color to the desired appearance. 
7) Change the button Effect to the desired appearance. 
8) Set the Effect Color as appropriate. 
9) To change the size of the button, set the Height and Width in pixels. 

10) Click [OK].  Before you can preview your button, you must first save the page. 
 
You can add as may buttons as you would like and have as many different effects.  However, as 
for any design, all the effects on a page/site should be the same, all your buttons should be together 
on a page, and should be in the same area from page to page. 
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PAGE PROPERTIES (OTHER): 
 
Background Sounds: 
You can play a sound as “background audio” to your page.  Be aware that this can add to your load 
time, as well as annoy visitors.  The sound/music should be appropriate to your page. 

1) Right-click on your page and choose “Page Properties”. 
2) Choose the “General” tab. 
3) Under “Background Sound”, choose the file location. 
4) Choose to “Loop Forever” or specify how may times the sound will loop. 

 
Hyperlink Text Rollovers: 
Rollovers are similar to what was covered on the previous page (Hyperlink ‘Hover Buttons’).  This 
is just an easier way to use FP to do the same thing.  To give your hyperlink links some pizzazz 
when visitors move their mouse over them: 

1) Right-click on your page and choose “Page Properties”. 
2) Choose the “Background” tab. 
3) Check “Enable Hyperlink Rollover Effects”. 
4) Click the [Rollover Style] button. 
5) Choose the style of font you want the hyperlinks to change to when the user’s mouse 

moves over the hyperlink.  Note: this will change all the text hyperlinks on your page. 
 
 
META TAGS: 
META tags are usually the first lines of HTML code.  They are used for many different 
purposes, but most commonly contain either information about the history of the page or 
instruction for how the browser should handle the page. 
 
How to work with META tags: 
1) Right-click on your page and choose “Page Properties”. 
2) Choose the “Custom” tab. 
3) Remove any META tags you do not need by selecting the tag and click the [Remove] button. 
4) To add a tag, click the [Add] button next to the appropriate field.  Enter the name and value 

of the tag (see examples below). 
 
Common META Tags: 
“Server Variables” 

 Desc: Refresh your page every X seconds, or jump to another page. 
Name: “Refresh” 
Value: “X;url=Y”  where X=number of seconds & Y=page to refresh/jump to. 

 Desc: provide keyword to help search engines index your page. 
Name: “Keywords” 
Value: “X”  where X=keywords in any fashion (do not use quotes). 

 
 “User Variables” 

 Desc: Restrict servers from indexing your page (hide it from search engines). 
Name: “robots” 
Value: “none” 



 29

COPY AND PASTE: 
 
With all the copyright restriction in the world today, web code is about the only thing that you can 
“borrow” from someone else and they will be happy to share their work with others.  For the most 
part, looking at and borrowing code from someone else is the best way to learn and build your 
website. 
 
There are several different ways you can find code to use for your sight.  The easy way is to go to 
a code library, search for the feature you are looking for (or just browse), and follow the directions 
on inserting it into your page.  The other method is to find a site that has something you want.  
You can then look at their code, find the portion that you want, and copy that for your page.  This 
later way does require much more understanding of web code in order to dig out the portion that 
you want. 
 
There are also several different kinds of web code that you can copy from.  Aside from HTML, 
there is also JavaScript (most popular), JAVA, and ASP.  For the beginner, I would stick with 
HTML and JavaScript.  If you would like to learn how to write your own scripts, there is a primer 
on our Web Design Page. 
 
Find Your Code (Library) and Add It: 
There are many sites that offer a library of “copy & paste” code for about any programming 
language you want.  For this class, we will stick with HTML and JavaScript. 

1) In IE, go to our Web Design Site and access any of these code libraries. 
2) Find the script/code that you want. 
3) Select all the code provided, then go to the menu and choose <Edit> Copy>. 
4) Click back to FP and click the “HTML” view tab for your page. 
5) Place your cursor in the area where the script should be inserted (as directed by the source 

site), right-click, and choose “Paste”. 
6) Modify the code as necessary adding your own custom setting or colors (as directed). 

 
Code often needs to be placed within two main locations, either the “Head” or the “Body”.  If the 
site states that code need to be placed in the Head, make sure to place it anywhere between the 
header tags: “<head> …. </head>”.  If it says body, place it between the body tags: “<body> …. 
</body>”.  Some web features may need code placed in both spots.  Pay attention to what needs to 
go where. 
 
If your code allows/requires custom color coding, you will need to specify colors by either the 
“given name” or a hexadecimal number.  Such easy names like “Red”, “Blue”, and “Black” are 
easier to use than a number.  However, for shades and hues of colors, it is often necessary to use 
an exact number.  A hexadecimal color number is made up a 6 digits that when put together 
specify an exact color.  The digits range from “0” (dark) to “F” (Light).  Positions 1 & 2 represent 
RED, 3 & 4 GREEN, and 5 & 6 BLUE (#RRGGBB).  Setting all numbers to F (#FFFFFF) 
produces WHITE, and all 0’s (#000000) makes BLACK.  For a visual listing of colors with their 
hexadecimal number, use one of the color chart sites listed on the Web Design Site.  Typically, 
color definitions will always be in quotes and hexadecimal numbers must always begin with a 
number sign (#). 
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Pull Code From A Site’s Source 
If you visit a website and would like to “borrow” a feature or code from them, follow one of these 
two methods.  This may require a little knowledge of HTML to know what code is required to be 
copied. 

1) In IE, go to the desired page.  Choose from the menu <View> Source>.  This will open a 
Notepad window with all the source code for that page.  Find the code you want, select it, 
and copy it.  Follow the directions above to paste the code into your page. 

2) Go to the page in IE.  Choose from the IE menu <File> Edit in FrontPage>.  The page will 
open as a copy in FP.  Simple copy the text from HTML view on the source page to your 
page.  Or if you like the design of the page, delete all the undesired or copyrighted content, 
and save it as your own. 

 
<<< On the Web Design Site, there is a link to JavaScript examples that are 
currently being used on Troy’s site.  Feel free to use them as you like. >>> 

 
 
 
 
 
ACTIVE SERVER PAGES (ASP) 
ASP pages are a broad classification of pages that can be changed/customized each time a user 
views the page.  This “active content” is usually pulled from the users PC, the server, or outside 
data like a database.  FP includes a wizard that will help you display content for a database.  You 
can also use custom coding to include “Visual Basic” script.  We will briefly cover highlights of 
both these options. 
 
“Database Results Wizard” 
The DRW is a FP wizard that will help you display data from a database.  Assuming you have a 
database already setup on the server, and a DB connection established (such as from the form 
above), you may continue. 

1) Place your cursor on the page where you want the database results to appear.  It will help 
to give yourself some room above and below. 

2) From the menu, choose <Insert> Database> Results>. 
3) Choose “Use Existing Database Connection” and choose your connection name form the 

list provided.  Click [Next]. 
4) In the Record Source field, choose the table/query in the database that you want to work 

with.  If you created a DB from a FP form, this will always be called “Results”.  [Next]. 
5) Click the [Edit List] button to choose which field you want to appear.  Click [OK]. 
6) Click [More Options]. 
7) Click [Criteria] to set the criteria for what records will be displayed.  You can choose to 

specify criteria values or let FP create a search form so users can enter custom values.  
Click [OK]. 

8) Click [Ordering] to choose the display order of the records.  Click [OK]. 
9) To limit the total number of records returned check the box and specify a number. 

10) Enter a message to display if no records were found.  Click [OK] and [Next]. 
11) Choose how you want the data to be formatted on your webpage.  Typically, “Table” or 

“List” is used. 
12) Specify the properties for the option you chose above and click [Next]. 
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13) Choose whether you want all your records to be display together on one page or broken 
up in a specified grouping of records on multiple pages. 

14) If you have field criteria where you need a search form, make sure that the option is 
check on this screen. 

15) Click [Finished]. 
 
FP will now display a rather coded structure of data that may not make a whole lot of sense.  
Basically, the yellow areas denote where the returned records will be displayed (between the 
yellow areas).  Items with double brackets ( << Item >> ) are a place-holder for that field value 
from the records to be returned.  It is manipulated as one element and can be formatted just like 
standard text (with the formatting applied to the value returned). 
 
To see how the data displays, you must save the page and view it in your web browser (the 
results will not show in “Preview” view). 
 
You can change the settings of the database region by double-clicking on the yellow areas and 
following the DRW again. 
 
There are lots of other tricks that you can do with the FP DRW.  If you have a specific idea in 
mind, please feel free to ask.  Many such tricks only make sense unless you have a reason to use 
them. 
 
 
 
Basic ASP Coding (w/ VB) 
Visual Basic is a general Microsoft scripting language that can be used in all Microsoft products 
and webpages.  There are many books available on VB and it is a great way of taking webpages, 
Access, and Excel to the next level. 
 
Most all VB coding will work on webpages as long as you denote it as such (must be 
distinguishable from HTML coding).  This means, put all your ASP coding within these tags:  
<% ASP CODE %>. 
 
On your web page, go into HTML view.  Familiarize yourself with where you want to put the 
ASP code.  [Tip: in Normal view, enter some text, like “ASP Here” to denote where the code 
should be placed in HTML view.]  ASP code will never show up in normal view, so you always 
need to work in HTML and need to pay attention to where you are in the document. 
 
You can place a single line of code that will display something simple, or write several lines to 
calculate something more complex.  An example of a single line is “<%=date()%>” (notice the 
ASP tabs tight in with an equal sign which means something will be written to the page). 
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Multi-line ASP usually has the start and end ASP tags on separate lines with each line of code in 
between.  Here is an example: 
 <% 
 if time() < “12:00” then 
 response.write “Good Morning” 
 else 

response.write “Good Afternoon” 
end if 
%> 

 
To view your ASP code, you must preview in your web browser.  The following page contains 
some simple ASP/VB codes/commands. 
 
 
SAMPLING OF ASP CODES 
 
 Variables 
Date() Current date. 
Time() Current time. 
Now() Current date + time 
Request.Form(“field”) Displays the value of the specified “field” sent for a form on a 

previous page. 
Request.Querystring(“name”) Displays the value of the specified value “name” from the URL.  

Use a link to this page and include 
“…thispage.asp?name=value”. 

 
 Comparisons 
If [variable] = X Then 
   (Action) 
Else 
End If 

Does action if variable meets criteria.  For comparison, use “=” 
for equal to, “<” less than, “>”greater than, and “<>” for NOT 
equal.  For X, use a number or a string in quotes (ex: V=”John” 
or V=5).  For (Action), use any of the actions below.  Use of 
“Else” is not required, but “End If” is. 

 
 Actions 
Response.write “text” Writes text (or value) to the web page. 
Response.redirect “URL” Redirects the webpage to the specified URL location. 
UCase(x) or LCase(x) Makes x all upper or lower case. 
 
There are literally hundreds of more commands and variables that you can use.  For a complete 
list, use the provided links on our Web Design page.  If you can handle a little bit of logic or 
algebra, this should be easy to grasp. 
 
Codes, like those listed above, can easily be used with database result fields (DRW).  If you look 
at each field item in HTML, you will see that in the root of the code, the field name is within 
ASP tags. 
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CREATING PDF FILES FOR THE WEB 
TCS supports a free application called “PDFCreator”.  This application works like a standard printer 
queue, but instead of printing to paper, it prints to a PDF file that can then be posted on the web. 
 

THS and select locations now have Adobe PDF Maker.  If you have this version of the printer 
installed, please reference the Adobe Acrobat notes for making PDF files before using the 
instruction below for posting to the web. 
 

Install Network Version of PDFCreator: 
Only do this if you do not have “Adobe PDF” as a printer option.  Before you begin, make sure 
you know what your home building is for your U:\ drive (can be found by looking at your U:\ drive 
under My Computer and seeing what server/building is listed as “<your_username> on 
<server_name>”.  You must always install using your home building no matter where you are at! 

1. Go to [Start]  Run. 
2. Type in two back slashes (\\), followed by the server name above, and then followed by 

PDFCreator (example: \\trcn1\PDFCreator). 
3. Click Yes to add the printer.   
4. You will now have the PDFCreator printer under your account.  It will only show on your 

account and will follow you from computer to computer. 
 

Using the Network Version of PDFCreator: 
1. In any program, create a document or report just the way you want it. 
2. Go to File>Print (or which ever method you use to send it to a standard printer). 
3. From the drop-down list of printers, select PDFCreator.  
4. Select any print options you want and Print the document normally. 
5. There will be no additional prompts for saving the PDF file. 
6. Go to your U:\ drive and locate the PDF folder. 
7. You will find the file you just printed is saved here.  The PDFCreator will default to saving 

the file with the same file name as your original document, but with a .PDF file extension. 
 

TO POST PDF FILES TO THE WEB SERVER: 
If you want your PDF document to be part of your website, you must copy it correctly to the 
server, and link it from your web page. 

1. Select the PDF file(s) you want to put on the web.  Right-click on the files and choose Copy. 
2. Open FrontPage to your building’s web.  Locate the folder in the root named PDF.  

Locate your folder inside the PDF folder.  If you do not have one, create one as per the 
guidance of the building webmaster. 

3. Right-click on your folder and choose Paste.  This will copy your files to the web server. 
4. Open the page on which you want to post links to these PDF files. 
5. Type the text for the hyperlinks to the PDF files.  Make standard hyperlinks of the text by 

browsing to your folder under the main PDF folder.  Choose each file to make the links. 
6. Save your page, check to make sure the links work, and you are done. 

 

Note:  To simply update PDF documents that do not require new hyperlinks, just overwrite the 
PDF file in PDF folder with the new file of the same name.  The link will not notice the change. 
 

PDF files must be placed is designated folders.  These folders have a special setup that will 
allow PDF files to work normally.  Placing PDF files outside these folders will cause guests to 
get error messages about a corrupt file! 
 
 
If you ever have any questions related to FrontPage or web page design, feel free to contact me, Scott Hamman, either via e-mail or phone.  I will 
try my best to help, but be understanding if I don’t always have time to give extensive one-on-one assistance. 


